2.21. Etherchannel (PAgP y LACP)


Teoría Etherchannels, configuración y verificación




Balanceo de carga en Etherchannels



Nota: Lastimosamente el contenido completo solo está disponible para miembros… por favor suscríbete

PREGUNTAS!

Las preguntas que encontraras en esta sección, son similares a las que te encontraras en el examen de certificación.
 
logo
SI QUIERES DISFRUTAR DE ESTE CONTENIDO, TE INVITAMOS A QUE TE SUSCRIBAS.

¡PARTICIPEMOS!

Si te quedaron dudas de la lección, escríbela a continuación y así todos podemos participar y ayudarte.
¿Quieres participar en los debates?… por favor suscríbete

NUESTROS CURSOS Foros Etherchannel (PAgP y LACP)

Viendo 13 entradas - de la 1 a la 13 (de un total de 13)
  • Autor
    Entradas
  • #11410
    AdminNG
    Superadministrador
    #17310
    Hebert Delgadillo
    Participante

    Escribi un mensaje y no estoy seguro de si solo tardó en subirse o no se envió.

    #17311
    Hebert Delgadillo
    Participante

    Topologia

    Buenas tardes…
    Construi la topologia de la imagen, y no entiendo porque hay un sector todo verde, converti en etherchannel los cables entre el switch 0 y 2. Al ejecutar show spanning-tree, note que al unir en etherchannel a 2 interfaces el costo reducio. Pero solo en la Vlan 1 aparece el puerto Etherchannel en las otras es como si no existiera, y no lo entiendo ayuda por favor..

    #17308
    Hebert Delgadillo
    Participante

    Topologia en packet tracer


    Buenas tardes…
    Construí la topología de la imagen, todo estaba bien hasta que decidí, hacer un etherchannel entre el Switch 0 y 2 (están en la imagen).
    Resulta que al crear un Etherchannel el costo de la interfaz reduce en el eherchannel, por lo que la topología cambia, hasta ahi todo bien. Lo que no entiendo es que al momento de ejecutar «show spanning-tree» en el Switch 2, da una topología para la Vlan 1 (que es correcta considerando el nuevo coste de interfaz), pero para el resto de Vlans es como si el Etherchannel no existera. Por otro lado en el diagrama todo esta en verde en ese sector como si hubiera posibilidad de loop. La verdad no lo entiendo, ayuda por favor..

    #17328
    AlvaroM
    Superadministrador

    Hola Hebert buenas noches!

    Para subir fotos, tienes que colocar la URL de la imagen exacta y no la URL de la página web, es por eso que no se ven tus imágenes en el foro.

    He visto tus imágenes de manera interna, y lo que puedo concluir al ver esas imágenes, es que tu Etherchannel está funcionando en modo acceso en la VLAN 1, no está funcionando como troncal y es por eso que no ves al Etherchannel como parte de las otras VLANs… realiza esa verificación y coméntame como te va.

    Respecto a tu segunda consulta, cuando tienes un Etherchannel creado, las interfaces que forman parte del Etherchannel NO tienen porqué bloquearse, no deberías ver puertos amarillos dentro de un Etherchannel, desde la perspectiva de Spanning-tree solo existe 1 puerto lógico, Spanning-tree no conoce las interfaces físicas 1 y 2 que forman tu Etherchannel, este comportamiento es normal y no debería generar loops si configuraste el Etherchannel de manera adecuada.

    No te recomiendo basarte en los “colores” de los leds en Packet Tracer para definir si una interface está bloqueada o no en Spanning-tree, la información que te interesa es la que obtienes cuando ejecutas

    show spanning-tree

    mira que en tu caso no aparecen tus interfaces 1 y 2, sino que en su lugar aparece la interface lógica Po2 y ahí te indica que interfaces está bloqueadas para tu VLAN.

    Atento a tus comentarios!

    Saludos cordiales.

    #17346
    Hebert Delgadillo
    Participante

    Aunque no parezca es un error de packet tracer. Abri el archivo que guarde, y todo apareció correctamente, Po2 aparecia en todas la Vlan, lo cual me impresionó, luego separé el etherchannel deje que spanning-tree haga sus calculos y luego volvi a hacer un etherchannel para dejar todo como antes, y otra vez ese error, mi version de packet tracer es la 7.3.0 y puede probarse.

    #17365
    AlvaroM
    Superadministrador

    Hola Hebert!

    Si gustas mandame el archivo a alvarom@netwgeeks.com para ver si a mi también me pasa este error!

    Atento a tus comentarios! =)

    Saludos

    #19393

    Estimado, veo que en el ejemplo final del video 2, el SW2 tiene diferentes configuraciones de balanceo según su interfaz, los comandos de la presentación cambian el modo de balanceo de manera general?.. cual sería el comando para configurarlos individualmente?

    #19402
    AlvaroM
    Superadministrador

    Hola Javier!

    En realidad NO puedes realizar una configuración de balanceo de carga a nivel de port-channels dentro de un mismo switch. Los cambios de balanceo de carga se aplican a TODOS los Etherchannels en un mismo switch.

    Hemos editado/eliminado ese ejemplo del video ya que causara confusión. Sin embargo no te preocupes mucho por este tema, de este tema lo máximo que te podrían preguntar es el método por defecto utilizado para realizar balanceo de carga. Disculpa por la confusión generada.

    Acá tienes la página oficial de Cisco sobre el balanceo de carga en los switches 2960: https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst2960/software/release/12-2_53_se/configuration/guide/2960scg/swethchl.html#78975

    Saludos cordiales!

    #21367
    Ricardo Casillas
    Participante

    Buen día Álvaro
    Referente a la pregunta 6, me podrías explicar la respuesta, no se deben de tener el mismo numero de etherchannel para que se configure? o es por que se refiere a las interfaces de un mismo switch?
    6. 2 interfaces de 2 switches se interconectan. En una interface tenemos el comando «channel-group 1 mode on» y en otra interface tenemos el comando «channel-group 12 mode on». ¿Qué afirmaciones son correctas?
    • El Etherchannel se formara correctamente

    También referente al balanceo , el modo debe ser el mismo de los dos lados? o pueden ser diferentes, mi duda es por el ejemplo, ya que de un lado se adecua mejor el src-mac y del otro el dst-mac

    Gracias de antemano.

    #21375
    AlvaroM
    Superadministrador

    Hola Ricardo!

    Gracias por la observación, en realidad la pregunta se refería a que los puertos se encontraban en diferentes switches, hemos modificado la pregunta para evitar confusiones. Ahora la pregunta es la siguiente:

    Las interfaces FA0/1 y FA0/2 del Switch 1 se conectan con las interfaces FA0/1 y FA0/2 del Switch 2. En las interfaces del Switch 1 tenemos configurado el comando «channel-group 1 mode on» y en las interfaces del Switch 2 tenemos configurado el comando «channel-group 12 mode on». ¿Qué afirmación es correcta?.

    Respecto a tu segunda consulta, el balanceo de carga se configura de manera global en CADA SWITCH, no es necesario que el switch vecino tenga el mismo mecanismo de balanceo, si ambos switches tendrían que utilizar el mismo balanceo de carga, tendríamos resultados que no son óptimos para el envío de tráfico… si en el caso de la topología del video, tu cambias el balanceo de carga en ambos switches a DST-MAC, esto quiere decir que las 4 PCs enviarían datos al servidor utilizado SOLO 1 interface del etherchannel, la segunda interface del etherchannel no se utilizaría para nada y seguramente tendrías congestión en esa interface utilizada. La respuesta del servidor sí tomaría un camino más adecuado al basarse en la dirección MAC de destino… podría enviar los datos a la MAC 0001 y 0002 por la interface fastethernet0/2, y los datos a la MAC 0003 y 0004 por la interface fastethernet0/3… pero de nuevo, esto no va servir de mucho si la vuelta solo circula por una interface. Lo más adecuado como lo mencionamos en la clase, sería que el switch 1 utilice un balanceo de carga SRC-MAC y el switch 2 utilice un balanceo de carga DST-MAC. La verdad hay que analizar cada situación para ver qué mecanismo sería el más adecuado, no hay una regla de oro que te permita definir el mejor balanceo de carga en todas las situaciones.

    Espero haberte ayudado y estoy atento a tus comentarios.

    Saludos cordiales! =)

    • Esta respuesta fue modificada hace 1 año, 1 mes por AlvaroM.
    #25598
    DiegoAv
    Participante

    Buenas tardes, podrías explicar la respuesta de esa pregunta porque no entiendo porque se establece el etherchannel si esta en modo ON y no están conectados los switches

    6. Las interfaces FA0/1 y FA0/2 del Switch 1 se conectan con las interfaces FA0/1 y FA0/2 del Switch 2. En las interfaces del Switch 1 tenemos configurado el comando «channel-group 1 mode on» y en las interfaces del Switch 3 tenemos configurado el comando «channel-group 12 mode on». ¿Qué afirmación es correcta?
    El Etherchannel se formara correctamente

    #25630
    AlvaroM
    Superadministrador

    Buenos días Diego!

    Mil disculpas, en una anterior modificación realizada a la pregunta 6 se nos fue el cambio del nombre al switch. En realidad se trata del Switch 1 y el Switch 2 (ya esta corregido). Al tener ambas interfaces conectadas entre sí con el modo ON, se formara el Etherchannel.

    Espero que ahora quede aclarado el panorama.

    Saludos cordiales.

    • Esta respuesta fue modificada hace 1 año, 1 mes por AlvaroM.
    • Esta respuesta fue modificada hace 1 año, 1 mes por AlvaroM.
Viendo 13 entradas - de la 1 a la 13 (de un total de 13)
  • Debes estar registrado para responder a este debate.